当前位置:  首页  >  PHP资讯  >  业界资讯

ubuntu16.04下不能启动Steam的解决方法

这篇文章主要给大家介绍了关于在ubuntu16.04下不能启动Steam的解决方法,文中介绍的非常详细,对大家具有一定的参考学习价值,需要的朋友们下面来一起看看吧。

前言

之前卸过一次steam,因为Linux玩游戏确实体验没有Windows好. 最近想重新安装.我的系统版本已经升级到 Ubuntu 16.04 LST 版本,并且我的显卡是amd64.

安装steam后运行报错了:

 $ steam Setting up Steam content in /home/weapon/.local/share/Steam Running Steam on ubuntu 16.04 64-bit STEAM_RUNTIME is enabled automatically Installing breakpad exception handler for appid(steam)/version(0) libGL error: unable to load driver: r600_dri.so libGL error: driver pointer missing libGL error: failed to load driver: r600 libGL error: unable to load driver: swrast_dri.so libGL error: failed to load driver: swrast

这是Steam软件本身的bug.因为它软件会用自己携带的动态链接库.因此有可能与本机驱动无法加载的情况.

解决方法

将steam自身的库删除,让它用系统上的库.

 $ rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6 $ rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libgc‌​c_s.so.1

最后祝大家游戏玩得愉快.

总结

以上就是这篇文章的全部内容了,希望本文的内容对大家的学习或者工作能带来一定的帮助,如果有疑问大家可以留言交流,谢谢大家对的支持。

内容推荐:免费高清PNG素材下载
吐了个 "CAO" !
扫码关注 PHP1 官方微信号
PHP1.CN | 中国最专业的PHP中文社区 | PNG素材下载 | DevBox开发工具箱 | json解析格式化 |PHP资讯 | PHP教程 | 数据库技术 | 服务器技术 | 前端开发技术 | PHP框架 | 开发工具 | 在线工具
Copyright © 1998 - 2020 PHP1.CN. All Rights Reserved PHP1.CN 第一PHP社区 版权所有 京ICP备19059560号-4