当前位置:  首页  >  PHP教程  >  PHP 基础  >  开发经验

php虚拟机不支持php-PHP问题

php虚拟机确实已不再支持php,php虚拟机开发团队宣布HHVMv3.30将是最后一个支持php的版本,并从4.0起停止支持php。

此外,该版本增加了对 .hack 文件的支持,对 HSL 正则表达式的非实验性支持,并删除了几个 PHP 相关的行为,如:

● 删除 PHP 数组中存在的行为,但不删除 Hack Arrays 或 Hack Collections

● 删除需要检查或改变调用者的函数(或调用函数的方法),如 compact(), extract(), get_declared_variables(), func_get_args()

● 弃用参考手册

官方还表示,计划在下个版本中删除对

更多PHP相关知识,请访问PHP中文网!

以上就是php虚拟机不支持php的详细内容,更多请关注 第一PHP社区 其它相关文章!

吐了个 "CAO" !
扫码关注 PHP1 官方微信号
PHP1.CN | 中国最专业的PHP中文社区 | json解析格式化 | PHP资讯 | PHP教程 | 数据库技术 | 服务器技术 | 前端开发技术 | PHP框架 | 开发工具 | 在线工具
Copyright © 1998 - 2020 PHP1.CN. All Rights Reserved PHP1.CN 第一PHP社区 版权所有