当前位置:  首页  >  PHP教程  >  PHP 应用  >  代码收藏

MySQL卸载的问题_MySQL

MySQL卸载的问题
mysql卸载

在安装 MySQL-client-4.1.16-1.glibc23.rpm 的时候


显示与 mysql-3.23.54a-11 冲突 可是我把那些冲突的文件名前面全部都加上#改名


却 还在冲突! 默认安装的MYSQL只是换了个版本!


试图 添加删除程序卸载 却显示却少个软件包无法找到 卸不了!

QUOTE:
Preparing... ########################################### [100%]
file /usr/bin/mysql from install of MySQL-client-4.1.16-1.glibc23
conflicts with file from package mysql-3.23.54a-11
file /usr/bin/mysql_find_rows from install of MySQL-client-4.1.16-1.glibc23
conflicts with file from package mysql-3.23.54a-11
file /usr/bin/mysqlaccess from install of MySQL-client-4.1.16-1.glibc23
conflicts with file from package mysql-3.23.54a-11
file /usr/bin/mysqlbinlog from install of MySQL-client-4.1.16-1.glibc23
conflicts with file from package mysql-3.23.54a-11
file /usr/bin/mysqlcheck from install of MySQL-client-4.1.16-1.glibc23
conflicts with file from package mysql-3.23.54a-11
file /usr/bin/mysqldump from install of MySQL-client-4.1.16-1.glibc23
conflicts with file from package mysql-3.23.54a-11
file /usr/bin/mysqldumpslow from install of MySQL-client-4.1.16-1.glibc23
conflicts with file from package mysql-3.23.54a-11
file /usr/bin/mysqlimport from install of MySQL-client-4.1.16-1.glibc23
conflicts with file from package mysql-3.23.54a-11
file /usr/bin/mysqlshow from install of MySQL-client-4.1.16-1.glibc23
conflicts with file from package mysql-3.23.54a-11
file /usr/share/man/man1/mysql.1.gz from install of MySQL-client-4.1.16-1.glibc23
conflicts with file from package mysql-3.23.54a-11
file /usr/share/man/man1/mysqlaccess.1.gz from install of MySQL-client-4.1.16-1.glibc23
conflicts with file from package mysql-3.23.54a-11
file /usr/share/man/man1/mysqladmin.1.gz from install of MySQL-client-4.1.16-1.glibc23
conflicts with file from package mysql-3.23.54a-11
file /usr/share/man/man1/mysqldump.1.gz from install of MySQL-client-4.1.16-1.glibc23
conflicts with file from package mysql-3.23.54a-11
file /usr/share/man/man1/mysqlshow.1.gz from install of MySQL-client-4.1.16-1.glibc23
conflicts with file from package mysql-3.23.54a-11
file /usr/bin/mysqladmin from install of MySQL-client-4.1.16-1.glibc23
conflicts with file from package mysql-server-3.23.54a-11


可以用 rpm 命令强制 卸载 !!

rpm -e --nodeps (不检查依赖性 ) 数据包名


然后安装 新的 或者可以用

rpm -i --replacepkgs (强制重新安装已经安装的软件包 )

rpm -i --nodeps (不检查依赖性 ) 这2个 都可以 看你的选择


不过一般升级新版本 用 rpm -U 如果加 -test 的话可以先测试一下可以不可以升级 !!


MySQL-client-4.1.16-1.glibc23.rpm 这个应该是客户相关的 rpm 吧? 因为我很少这样升级rpm包。所以具体的情况不是很了解 !! 因为rpm包关联性很强,经常是安装中错误,然后找关联的包。再安装这个,有时会要找很多关联包,才能装完整

吐了个 "CAO" !
扫码关注 PHP1 官方微信号
PHP1.CN | 中国最专业的PHP中文社区 | PHP资讯 | PHP教程 | 数据库技术 | 服务器技术 | 前端开发技术 | PHP框架 | 开发工具 | PHP问答
Copyright © 1998 - 2020 PHP1.CN. All Rights Reserved PHP1.CN 第一PHP社区 版权所有