热门标签 | HotTags
当前位置:  开发笔记 > 编程语言 > 正文

每日一练ACM2019.04.14

2019.4.14第1001题:SumProblemProblemDescriptionHey,welcometoHDOJ(HangzhouDianziUniversityOnli

2019.4.14

 

第1001题:Sum Problem

 


Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
Input
The input will consist of a series of integers n, one integer per line.
Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
Sample Input
1
100
Sample Output
1

5050

 

解:

package Acm;
import java.util.Scanner;
public class test1 {
public static void main(String[] args)
{
Scanner input
=new Scanner(System.in);
int a;
int b;
int sum = 0;
while(input.hasNext())
{
a
=input.nextInt();
for(int i=1;i<=a;i++){
sum
=sum+i;

}

System.out.println(sum);
//System.out.println();
sum=0;
}

}
}

 


推荐阅读
author-avatar
赵博钧石博
这个家伙很懒,什么也没留下!
PHP1.CN | 中国最专业的PHP中文社区 | DevBox开发工具箱 | json解析格式化 |PHP资讯 | PHP教程 | 数据库技术 | 服务器技术 | 前端开发技术 | PHP框架 | 开发工具 | 在线工具
Copyright © 1998 - 2020 PHP1.CN. All Rights Reserved | 京公网安备 11010802041100号 | 京ICP备19059560号-4 | PHP1.CN 第一PHP社区 版权所有