6赞
570
当前位置:  开发笔记 > 编程语言 > 正文

Maven项目指定JDK版本

博客分类:配置管理mavenJDK编程ApacheXML在主pom.xml文件中,增加如下配置!
博客分类: 配置管理
maven JDK 编程 Apache XML

    在主pom.xml文件中,增加如下配置!

 

 

Xml代码   收藏代码
  1. <build>  
  2.     <plugins>  
  3.       <plugin>  
  4.         <groupId>org.apache.maven.pluginsgroupId>  
  5.         <artifactId>maven-compiler-pluginartifactId>  
  6.         <configuration>  
  7.           <source>1.5source>  
  8.           <target>1.5target>  
  9.         configuration>  
  10.       plugin>  
  11.     plugins>  
  12. build>  
  13.    



org.apache.maven.plugins
maven-compiler-plugin

1.5
1.5




 

问题特征:

--------------------------------------------

1、请使用 -source 5 或更高版本以启用泛型”的异常信息,原因是你的应用中使用了JDK1.5的新特性:泛型编程,而Maven默认采用的JDK为JDK1.3。

2、

 


推荐阅读
author-avatar
zpcbb80569
这个家伙很懒,什么也没留下!
PHP1.CN | 中国最专业的PHP中文社区 | DevBox开发工具箱 | json解析格式化 |PHP资讯 | PHP教程 | 数据库技术 | 服务器技术 | 前端开发技术 | PHP框架 | 开发工具 | 在线工具
Copyright © 1998 - 2020 PHP1.CN. All Rights Reserved | 京公网安备 11010802041100号 | 京ICP备19059560号-4 | PHP1.CN 第一PHP社区 版权所有