当前位置:  首页  >  服务器技术  >  Linux/unix  >  Linux系统

GStreamerinstallforDebianetch

GStreamerinstallforDebianetch--Linux发行版技术-Debian信息,下面是详情阅读。
曾经在下面连接里说了编译gstreamer程序需要pkg-config

http://hi.baidu.com/gddark/blog/ ... f3a0c57931aaab.html

那时候是用源码装的GStreamer
所以pkg的时候没有问题

今天按照官网说的直接用apt安装GStreamer
http://gstreamer.freedesktop.org/download/

Debian and Ubuntu
GStreamer and the various plugins modules are available in both Debian and Ubuntu. You can install the most important ones with
sudo apt-get install gstreamer0.10-tools gstreamer0.10-x gstreamer0.10-plugins-base gstreamer0.10-plugins-good gstreamer0.10-plugins-ugly gstreamer0.10-plugins-bad gstreamer0.10-ffmpeg gstreamer0.10-alsa gstreamer0.10-schroedinger gstreamer0.10-pulseaudio
但是最后两个包找不到,就没装。
(lenny 里有后面两个包!但没发现什么影响。)
装完
$gst-inspect-0.10
Total count: 103 plugins, 462 features
(lenny下面的插件数目有:
Total count: 167 plugins, 744 features)

但是编译gstreamer程序的时候pkg找不到!
Package gstreamer-0.10 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gstreamer-0.10.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gstreamer-0.10' found

Google之
http://ubuntuforums.org/showthread.php?t=680646
提到要安装 libgstreamer-0.10-dev
apt之
问题解决。

PS:之前用源码包装的时候不知道少装了什么插件,找不到 equalizer-nbands 工厂!
所以才重装的。原来apt就有。
自己不仔细看官网的文档,呵呵。
不过貌似etch的GStreamer版本有点老,先看看有没有什么问题吧。
(现在用apt装的还是找不到!而换一个虚拟机用lenny,装上就可以找到工厂!莫非项目又要换环境。)
吐了个 "CAO" !
扫码关注 PHP1 官方微信号
PHP1.CN | 中国最专业的PHP中文社区 | PHP资讯 | PHP教程 | 数据库技术 | 服务器技术 | 前端开发技术 | PHP框架 | 开发工具 | PHP问答
Copyright © 1998 - 2020 PHP1.CN. All Rights Reserved PHP1.CN 第一PHP社区 版权所有