当前位置:  首页  >  服务器技术  >  Linux/unix  >  Linux系统

Fedora15降级安装GCC-4.5.3全过程以及遇到的问题和解决办法总结

在这篇配置Linux系统下CUDA环境的文章提到(见http://www.linuxidc.com/Linux/2011-12/49874.htm),目前CUDA最新的版本4.1版本只支持gcc4.6版本以下的,而我的Fedora中的gcc是4.6.1的,为此需要将gcc降低版本,只要牵涉到修改gcc的就比较麻烦,而降低gcc版本更是复杂了,特此整理如下。我用的是Fedora

在这篇配置Linux系统下CUDA环境的文章提到(见 http://www.linuxidc.com/Linux/2011-12/49874.htm ),目前CUDA最新的版本4.1版本只支持gcc4.6版本以下的,而我的Fedora中的gcc是4.6.1的,为此需要将gcc降低版本,只要牵涉到修改gcc的就比较麻烦,而降低gcc版本更是复杂了,特此整理如下。

我用的是Fedora 15,里面的 gcc编译目前的最新版本是4.6.1。

1.首先在配置gcc的过程中会出现错误:gcc configure: error:Building GCC requires GMP 4.2+, MPFR 2.3.1+and MPC 0.8.0+。这说明要安装gcc需要GMP、MPFR、MPC这三个库,可从网上下载相应的压缩包。

由于MPFR依赖GMP,而MPC依赖GMP和MPFR,所以要先安装GMP,其次MPFR,最后才是MPC。这里三个库我用的版本分别是gmp4.2,mpfr2.3.1和mpc0.8.0。

先开始安装GMP。解压GMP的压缩包后,得到源代码目录gmp-4.2(tar  jxvf  gmp-4.2.tar.bz2  –C /usr/local/,此处将gmp-4.2解压到/usr/local/)。在该目录的同级目录下建立一个临时的编译目录,这里命名为gmp-build(mkdir /usr/local/gmp-build)。然后开始配置安装选项,进入gmp-build目录,输入以下命令进行配置:

/usr/local/gmp-4.2/configure  --prefix=/usr/local/gmp-4.2

这里--prefix选项代表要将该库安装在哪里,我是装在/usr/local/gmp-4.3.2目录下,后面的安装都会用到这个选项。 

这时在gmp的编译目录下就会生成一个makefile文件,现在开始编译安装。

make

make check

sudo make install

这样就安装好了gmp。


2.mpfr和mpc的安装方法与此类似。不过要注意配置的时候要把依赖关系选项加进去,具体后面两个库配置命令如下:

/usr/local/mpfr-2.3.1/configure  --prefix=/usr/local/mpfr-2.3.1  --with-gmp=/usr/local/gmp-4.2

/usr/local/mpc-0.8/configure  --prefix=/usr/local/mpc-0.8   --with-gmp=/usr/local/gmp-4.2   --with-mpfr=/usr/local/mpfr-2.3.1

安装好这三个库之后,就可以正式开始安装gcc了。


3.与此前一样,先建一个编译gcc的临时目录gcc-build,进入该目录后配置安装选项:

/usr/local/gcc-4.5.3/configure   --prefix=/usr/local/gcc-4.5.3  --enable-threads=posix   --disable-checking   --disable-multilib  --enable-languages=c,c++,java   --with-gmp=/usr/local/gmp-4.2   --with-mpfr=/usr/local/mpfr-2.3.1   --with-mpc=/usr/local/mpc-0.8

gcc的配置选项有很多,具体可以参考gcc源文件目录下的安装说明。这里只安装了c、c++和java的编译器。(如果不指定编译的语言,则会在make时不通过,爆出某些文件找不到等错误,所以还是建议在此指定编译语言为c,c++,java)然后开始make编译。为保险起见,需要在环境变量LD_LIBRARY_PATH添加前面三个库的位置,键入以下命令(具体是):

vim  /etc/profile   ,即编辑profile文件,还需要修改读写权限,用chmod o+w  /etc/profile。再在最后添加如下代码:

expor

LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/mpc-0.8/lib:/usr/local/gmp-4.2/lib:/usr/local/mpfr-2.3.1/lib

 

然后重新make编译,在经过漫长的1小时等待后,终于编译完成。在安装说明里面还有测试这一步,不过那是可选的。直接make install安装,至此gcc就全部安装完成了。不过目前还不能使用新版本的gcc,因为新版的可执行文件还没加到命令的搜索路径中。在这里我为新版的 gcc和g++命令分别建立了一个软链接。进入/usr/bin目录后,键入如下命令建立软链接。

sudo ln -s /usr/local/gcc-4.5.3/bin/gcc   gcc45

sudo ln -s /usr/local/gcc-4.5.3/bin/g++  g++45

这样我使用新版本gcc的时候就可以用gcc45和g++45命令,同时也可使用原来的gcc编译程序。当然这里也可以直接将/usr/bin目录下gcc,g++命令重新链接到新版本的gcc可执行文件。在正式使用之前还有最后一个工作要做,就是将前面安装的三个库的路径加进环境变量LD_LIBRARY_PATH中,不然在编译程序的时候会出错。由于我不想每次编译程序都生成环境变量,所以需要编辑/etc目录下的bashrc文件 配置shell环境。在这个文件中添加以下语句:

LD_LIBRARY_PATH=:/usr/local/mpc-0.8/lib:/usr/local/gmp-4.2/lib:/usr/local/mpfr-2.3.1/lib:/usr/local/gcc-4.5.3/lib

export LD_LIBRARY_PATH

保存重启系统后,就可以使用新装的gcc了。

以上就是我在Fedora 15安装gcc4.2.0的全过程。

 

 4.  我在/usr/bin 目录下关于gcc、g++ 的文件主要有以下四个: 

gcc        g++ 

gcc45    g++45 

上面一行的是原来的高版本的4.6.1的gcc版本,下面一行是新安装的低版本的4.5.3的gcc版本的软链接(我理解为就是低版本的gcc本身),现在系统默认执行gcc还是4.6.1的gcc,执行gcc45就是4.5的gcc,我在编译其他源码的时候,由于是configure配置的,需要修改默认的系统gcc版本,所以我把这个目录下的原来的gcc 改名为gcc.bak(mv /usr/bin/gcc  /usr/bin/gcc.bak) ,把gcc45改名gcc(mv  /usr/bin/gcc45  /usr/bin/gcc),这样我的默认的gcc环境就是低版本4.5.3的了,g++(mv  /usr/bin/g++  /usr/bin/g++.bak ;mv  /usr/bin/g++45  /usr/bin/g++)也一样操作。

当需要改回默认设置是高版本时候,执行反操作,把gcc改成gcc45,把 gcc.bak 改成gcc,就是高版本的4.6.1为默认了,g++的改名也一样操作。


5.安装完gcc并重启后,发现系统很慢了,而且firefox浏览器、文件系统等都打不开了,只有终端能打开了,很郁闷啊,问题还没完全解决呢,又出现了一个问题啊,于是又费了好大的劲才弄好。

首先,在终端输入命令 firefox,然后出现错误提示:Couldn‘t load XPCOM。这个问题很奇怪,其他什么都没有,我在网上查了查,没有类似的问题。我当时用的是firefox 7.0版本的,后来就升级了一下,用  yum  update  firefox,更新完毕后,又用命令 firefox试了试,这时出现问题如下:

XPCOMGlueLoad  error  for  file  /usr/lib/xulrunner-2/libxpcom.so:  /usr/local/gcc-4.5.3/lib/libstdc++.so.6:  version        'GLIBCXX_3.4.15'  not  found  (required  by  /usr/lib/xulrunner-2/libxul.so)

Couldn't  load  XPCOM.

后来,又在网上查阅资料,才弄明白,也费了一番周折的。

执行命令:strings /usr/local/gcc-4.5.3/lib/libstdc ++.so.6 | grep GLIBC    显示如下:

GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8

GLIBCXX_3.4.9

GLIBCXX_3.4.10

GLIBCXX_3.4.11

GLIBCXX_3.4.12

GLIBCXX_3.4.13

GLIBCXX_3.4.14
GLIBC_2.0
GLIBC_2.3
GLIBC_2.1
GLIBC_2.1.3
GLIBC_2.3.2
GLIBC_2.2
GLIBCXX_FORCE_NEW
GLIBCXX_DEBUG_MESSAGE_LENGTH

又执行 ls  -l  /usr/local/gcc-4.5.3/lib/libstdc ++.so.6   显示如下:

lrwxrexrwx. 1  root  root  19  12月  19  19:00  /usr/local/gcc-4.5.3/lib/libstdc++.so.6 -> libstdc++.so.6.0.14

意思是低版本的gcc-4.5.3的libstdc++.so.6 与libstdc++.so.6.0.14建立了软连接。

重复上面的两行命令,只不过是用/usr/lib/libstdc++.so.6替换了 /usr/local/gcc-4.5.3/lib/libstdc++.so.6,可以查到这里包含‘GLIBCXX_3.4.15’,且软连接是:/usr/lib/libstdc++.so.6 -> libstdc++.so.6.0.16,显然是指原来高版本gcc-4.6.1的libstdc++.so.6 与libstdc++.so.6.0.16建立了软连接。而现在用了低版本的gcc-4.5.3,却缺少了GLIBCXX_3.4.15’,那么把

低版本的gcc-4.5.3的libstdc++.so.6 与libstdc++.so.6.0.16建立软连接,应该就可以解决这个问题了吧。

首先复制:cp  /usr/lib/libstdc++.so.6.0.16  /usr/local/gcc-4.5.3/lib/

然后建立软连接:ln  -s  /usr/local/gcc-4.5.3/lib/libstdc++.so.6.0.16  /usr/local/gcc-4.5.3/lib/libstdc++.so.6

试了试命令 firefox,发现可以打开浏览器了,文件系统也能打开了,这说明这个方法可行,虽然不明白其中的道理。

吐了个 "CAO" !
扫码关注 PHP1 官方微信号
PHP1.CN | 中国最专业的PHP中文社区 | PHP资讯 | PHP教程 | 数据库技术 | 服务器技术 | 前端开发技术 | PHP框架 | 开发工具 | PHP问答
Copyright © 1998 - 2020 PHP1.CN. All Rights Reserved PHP1.CN 第一PHP社区 版权所有