当前位置:  首页  >  服务器技术  >  Linux/unix  >  Linux教程

SUSELinux不安全权限处理漏洞

文章标题:SUSELinux不安全权限处理漏洞。Linux是中国IT实验室的一个技术频道。包含桌面应用,Linux系统管理,内核研究,嵌入式系统和开源等一些基本分类

  详细描述:
  
  SuSE Linux是一款开放源代码Linux系统。
  
  SuSE Linux对文件链接的属性检查存在漏洞,本地攻击者可能利用这个漏洞非授权读取敏感信息。
  
  SuSE Linux捆绑了3组预定义权限,分别是easy、secure和paranoid。permissions软件包所捆绑的chkstat程序可以检查这些权限并选择其中一个级别。easy级为默认的级别,允许一些完全可写的的目录,/usr/src/packages/RPMS及其子目录就是其中之一。为了防范用户的恶意行为,如链接到/etc/shadow,chkstat并不检查有count != 1硬链接的符号链接或文件。但上述检查中存在漏洞。恶意用户可以在chkstat修改的位置放置到/etc/shadow的硬链接,这样就可以访问该文件。chkstat不会检查该文件,因为它的硬链接计数为2。但是,如果管理员修改了用户数据库的话,就会删除并替换原始的/etc/shadow。这就意味着恶意用户所创建的文件硬链接计数可能降到1。这时chkstat就会将文件的权限修改为任何人都可以读取。因此从技术上来讲,chkstat可能以安全的方式修改文件权限。
  
  受影响系统:
  
  S.u.S.E. Linux Enterprise Server 8
  
  S.u.S.E. Linux Desktop 1.0
  
  S.u.S.E. Linux 9.3
  
  S.u.S.E. Linux 9.2
  
  S.u.S.E. Linux 9.1
  
  S.u.S.E. Linux 9.0
  
  S.u.S.E. Linux 10.0
  
  S.u.S.E. UnitedLinux 1.0
  
  S.u.S.E. SLES 9
  
  补丁下载:
  
  S.u.S.E.已经为此发布了一个安全公告(SUSE-SA:2005:062)以及相应补丁:
  
  SUSE-SA:2005:062:permissions
  
  链接:http://www.novell.com/linux/security/advisories/2005_62_permissions.html
吐了个 "CAO" !
扫码关注 PHP1 官方微信号
PHP1.CN | 中国最专业的PHP中文社区 | PHP资讯 | PHP教程 | 数据库技术 | 服务器技术 | 前端开发技术 | PHP框架 | 开发工具 | PHP问答
Copyright © 1998 - 2020 PHP1.CN. All Rights Reserved PHP1.CN 第一PHP社区 版权所有