当前位置:  首页  >  服务器技术  >  Linux/unix  >  Linux系统

Fedora13安装Fcitx4.0.0输入法和设置

默认情况下Fedora的库里面是有fcitx输入法的,但是版本很低在已经出现4.0版本的时候,库里面仍然是3.63,因此想要装fcitx就要用电手段了到fcitx的googlecode项目主页上可以看到动态2010-12-17fcitx更新4.0.1fcitx-configtool更新0.2.0fcitx-sunpinyin更新0.2.12010-11-28

默认情况下 Fedora的库里面是有fcitx输入法的,但是版本很低 在已经出现4.0版本的时候,库里面仍然是3.63,因此想要装fcitx就要用电手段了

到fcitx的googlecode项目主页上 可以看到

动态

2010-12-17fcitx 更新 4.0.1 fcitx-configtool 更新 0.2.0 fcitx-sunpinyin 更新 0.2.1

2010-11-28fcitx-sunpinyin 更新 0.2.0

2010-11-21版本管理改为 mercurial,将 fcitx-config 和 fcitx-sunpinyin 从 github 也迁移到了 google code。

2010-11-19发布 3.6.4,4.0.0

2010-11-09发布 4.0 rc1

2010-11-02删除了 svn 里的原本打算用来存储码表的 /extra 目录,并将被删除的一个码表压缩包移到了下载列表里。在 svn 里存储压缩包等二进制文件不是一个好的实践。

2010-10-12增加了 openSUSE 和 Fedora 的源,地址见右侧外部链接(External Links)(我要的就是这句话)

2010-09-23增加 PPA 源,(External Links)Google code 上的 deb 包将不再更新

 

于是按照说的去找 源 看到了 home:csslayer.repo

好 下载下来 放到 /etc/yum.repos.d里面

然后 yum makecache

然后就可以 sudo yum install fcitx

这样就可以安装最新版本的输入法了

装完后最好能够把自带的 ibus输入法 删除掉 sudo yum remove ibus

这样可能系统进入的时候 fcitx不能自动启动

这样做:

点击系统-->首选项-->启动应用程序 对话框中点击添加 名称 命令位置分别填上 fcitx fcitx 即可 这样注销之后 看看fcitx是不是自动启动了?

或者在~/.bashrc文件中添加如下语句

export XMODIFIERS="@im=fcitx"

export XIM=fcitx

export XIM_PROGRAM=fcitx

fcitx&

但是建议用第一种方法,我用第二种出现了打开终端 就又提示加载fcitx配置文件错误的问题

吐了个 "CAO" !
扫码关注 PHP1 官方微信号
PHP1.CN | 中国最专业的PHP中文社区 | PHP资讯 | PHP教程 | 数据库技术 | 服务器技术 | 前端开发技术 | PHP框架 | 开发工具 | PHP问答
Copyright © 1998 - 2020 PHP1.CN. All Rights Reserved PHP1.CN 第一PHP社区 版权所有