当前位置:  首页  >  服务器技术  >  Linux/unix  >  Linux系统

在Ubuntu上怎么连接装有iOS7的iPhone或iPad

在几个月前我买了一个安装了iOS7系统的iPhone5手机。当我试着把iPhone或者iPad连接到Linux电脑(Ubuntu和LinuxMint)上时,它能够被识别,会提示我:“是否信任这台电脑”?然后我心中默念“我会的”,选择了“信任”,在等待了几秒后,它又重新提示我“是否信任这台电脑&rdq

在几个月前我买了一个安装了iOS 7系统的iPhone 5手机。当我试着把iPhone或者iPad连接到Linux电脑(Ubuntu和Linux Mint)上时,它能够被识别,会提示我:“是否信任这台电脑”?

然后我心中默念“我会的”,选择了“信任”,在等待了几秒后,它又重新提示我“是否信任这台电脑”?我继续点了“信任”。然后又提示同样的问题。我感觉我的手机陷入了一个while(true)的死循环。在Ubuntu而在我的Ubuntu电脑上,它只是提示我的iPhone被锁定了,所以我不能访问上面的文件。

在网络上搜索了一会,我才知道这个iOS 7在Linux系统上是否信任这台电脑的死循环是一个已知的问题。

这实际上是iOS 7系统的一个新安全特性,针对解决假冒的iPhone充电器问题。既然这样,那这篇文章在说什么?有没有办法解决iOS 7在Linux系统中的“信任这台电脑”的问题?libimobiledevice库希望在1.1.6版本中去解决这个问题,只不过稳定版本却一直遥遥无期。 不过别灰心,你仍然可以使用libimobiledevice的非稳定版本,然后轻松地连接你的iPhone和Ubuntu。让我来告诉你,怎么把iPhone手机连接到Ubuntu 13.10或者Linux Mint 16上,而不会有“信任这台电脑”的麻烦。

在Ubuntu 12.04上解决iOS 7的“信任这台电脑”问题:

如果你安装的是Ubuntu 12.04 LTS(32位或64位)或者Linux Mint 13 Maya,你可以添加下面Ingo Haschler的PPA源:

  1. sudo apt-add-repository ppa:ingo/ios7support
  2. sudo apt-get update
  3. sudo apt-get upgrade

之后,libimobiledevice库(已经安装过)会升级到不稳定的1.6版本,然后重启你的电脑,再重新连接iPhone。现在,它应该可以正常使用了。

说明:

如果你碰到“锁定错误”,那么再试试下面的命令:

  1. sudo mkdir /var/lib/lockdown
  2. sudo chmod 777/va7Lib/lockdown

在Ubuntu 13.10上解决iOS 7的“信任这台电脑”问题:

对于资深的Linux用户,你可以从GitHub上下载源码然后自己编译。对于使用Ubuntu 13.10 64位Linux Mint 16 64位系统的用户,有个Iuri Diniz编译好的Debian包可以用,你可以下载安装这个.deb包,然后就可以很轻松地在Ubuntu 13.10 64位系统上看到你的iPhone了。

  • Ubuntu 13.10 & Linux Mint 16 64位系统可用的libimobiledevice 1.6

双击下载后的.deb文件进行安装。提醒一下,因为Ubuntu和Linux Mint默认已经安装了这个库,所以你看到的会是升级库libimobiledevice,而不是安装它。

在装好后,你的iPhone或者iPad应该可以正常连接电脑了。下面是一张我把我的iPhone连接到一台Ubuntu 13.10电脑上的截图。

我可以访问手机上的文件,还可以从Ubuntu传送文件到iPhone。它还会被Rythembox软件认到并开始同步歌曲。这不是第一次,我在把移动设备接到Ubuntu上碰到问题。上次,我写过怎么连接Kindle Fire HD和Ubuntu。

我希望这个快速教程也可以解决你可能碰到的“信任这台电脑”的死循环问题。如果这个方法管用,或者你仍然还是不能把你的饿iPhone连接到Ubuntu上,都可以联系我。Ciao

吐了个 "CAO" !
扫码关注 PHP1 官方微信号
PHP1.CN | 中国最专业的PHP中文社区 | PHP资讯 | PHP教程 | 数据库技术 | 服务器技术 | 前端开发技术 | PHP框架 | 开发工具 | PHP问答
Copyright © 1998 - 2020 PHP1.CN. All Rights Reserved PHP1.CN 第一PHP社区 版权所有