当前位置:  首页  >  服务器技术  >  Linux/unix  >  Linux系统

如何在Debian上安装ATI官方驱动

如何在Debian上安装ATI官方驱动--Linux发行版技术-Debian信息,下面是详情阅读。
参考了这篇文章:http://www.linuxquestions.org/qu ... debian-etch-441423/

这篇文章似乎缺少了一部,安装必要的packages。首先成为root用户。

apt-get update

apt-get install gcc-3.4 module-assistant buildessential fakeroot dh-make debconf libstdc++5 gcc-3.3-base

注意:不是所有的都需要安装,我默认安装 完毕系统,只需要安装两个包就可以了

apt-get install dh-make libstdc++5

下载官方软件包,我下载的时候是ati-driver-installer-8-7-x86.x86_64.run

sh ati-driver-installer-8-7-x86.x86_64.run --buildpkg Debian/etch

注意:如果你使用的不是这个系统或者版本,可以使用sh ati-driver-installer-8.24.8-x86.run --help,查看这个驱动所支持列表

运行后会生成一些deb安装包,不同系统结果不同。我只安装了其中的两个最主要的,其它的是可选的。

dpkg -i fglrx-driver_8.512-1_amd64.deb
dpkg -i fglrx-kernel-src_8.512-1_amd64.deb

接下来的步骤非常重要,这才是真正的安装,因为需要编译到内核。

module-assistant prepare
module-assistant auto-install fglrx

这时候你需要修改系统的配置文件/etc/X11/xorg.conf,让它使用最新的驱动了。

vim /etc/X11/xorg.conf

最简单的方式就是将"vesa"替换为"fglrx"。让后将分辨率修改为你需要的,我这里修改为了显示器支持的最高分辨率1680*1050

重新启动系统就好了

你可以登录后用命令行测试你所安装的驱动:
modprobe -v fglrx
fglrxinfo
fgl_glxgears
吐了个 "CAO" !
扫码关注 PHP1 官方微信号
PHP1.CN | 中国最专业的PHP中文社区 | PHP资讯 | PHP教程 | 数据库技术 | 服务器技术 | 前端开发技术 | PHP框架 | 开发工具 | PHP问答
Copyright © 1998 - 2020 PHP1.CN. All Rights Reserved PHP1.CN 第一PHP社区 版权所有