当前位置:  首页  >  前端开发  >  CSS+DIV

不同版本IE使用不同css(css条件注释语句用法)_CSS/HTML

本文讲的是利用if来判断用户浏览器不同版本IE使用不同css,下面总结一些针对IE6、7、8条件注释语句用法
一、条件注释简介
1.IE中的条件注释(Conditional comments)对IE的版本和IE非IE有优秀的区分能力,是WEB设计中常用的hack方法。
2.条件注释只能用于IE5以上。
3.如果你安装了多个IE,条件注释将会以最高版本的IE为标准。
4.条件注释的基本结构和HTML的注释()是一样的。因此IE以外的浏览器将会把它们看作是普通的注释而完全忽略它们。
5.IE将会根据if条件来判断是否如解析普通的页面内容一样解析条件注释里的内容。
二、条件注释属性
gt : greater than,选择条件版本以上版本,不包含条件版本
lt : less than,选择条件版本以下版本,不包含条件版本
gte : greater than or equal,选择条件版本以上版本,包含条件版本
lte : less than or equal,选择条件版本以下版本,包含条件版本
! : 选择条件版本以外所有版本,无论高低
1、Css if hack条件语法
< !--[if IE]> Only IE
仅所有的WIN系统自带IE可识别

< !--[if IE 5.0]> Only IE 5.0
只有IE5.0可以识别

< !--[if gt IE 5.0]> Only IE 5.0+
IE5.0包换IE5.5都可以识别

< !--[if lt IE 6]> Only IE 6-
仅IE6可识别

< !--[if gte IE 6]> Only IE 6/+
IE6以及IE6以下的IE5.x都可识别


仅IE7可识别

< !--[if gte IE 7]> Only IE 7/+
IE7以及IE7以下的IE6、IE5.x都可识别


仅IE8可识别


仅IE9可识别

注:在 if 后加 lt gte有不同效果 (参加其它参数同理)
= IE8 仅IE8可识别
= IE7或更低版本
= 高于或者等于IE8版本
下面的代码是在非IE浏览器下运行的条件注释

您使用不是 Internet Explorer


您正在使用Internet Explorer version 6或者 一个非IE 浏览器

代码如下:






DIV IF条件实例


你正在使用:








说明:如果你的浏览器版本为多少即会显示IE多少,针对IE6-IE9实验

吐了个 "CAO" !
扫码关注 PHP1 官方微信号
PHP1.CN | 中国最专业的PHP中文社区 | PHP资讯 | PHP教程 | 数据库技术 | 服务器技术 | 前端开发技术 | PHP框架 | 开发工具 | PHP问答
Copyright © 1998 - 2020 PHP1.CN. All Rights Reserved PHP1.CN 第一PHP社区 版权所有